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Make a quick start! 
Thank you for selecting Trimble TILOS scheduling software. This Getting Started Guide will 
provide you (as a TILOS beginner) with a set of fundamental skills for creating a linear 
construction project schedule.  
 
There is a lot of complexity and power in TILOS, but we have simplified this guide to 
include just the basic, yet a complete, workflow for scheduling a project on your own. 
Immediately “getting your hands dirty” in this way will help to quickly build your ‘mental 
model’ about how TILOS works before you approach the next level of features and 
functionality. 
 
The guide consists of numbered steps, as well as supporting information that is formatted 
like this: 

Boxes like this contain supplemental text about the subject you are working through 
(meaning you can skip it if you just want to get through the steps). 

For in-depth, conceptual information, you should (of course) press F1 to see the 
context-sensitive TILOS help. 
 
By becoming familiar with TILOS 10.2 and its features through this exercise, plans like the 
one shown on the next page can be produced in a short period of time. In this exercise, 
you will start with a template that contains some of the cells you need, but also create 
some ‘from scratch’ in a new view so you learn how to do it. 
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Prerequisites 
● TILOS version 10.2 installed 
● A standard or higher license; to see what you are licensed for, select Help > 

License Manager. If you are not licensed, contact your dealer for help. 

Recommendation 
Use two monitors side-by-side, one for this guide and one for the program. Otherwise, you 
may find it easier to print this document so that you can maximize the program on your 
monitor. Working from a printed copy also prevents focus issues caused by switching back 
and forth between the online PDF and the program. 
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Start and Configure a New Project 

Create a Project from a Template 
1. Start TILOS. 

2. In the startup dialog, click the New project tab (or select File > New on the menu if 
you already have the program running).

 

3. Double-click the General.hst template. This template contains the most generic and 
commonly used project settings. 

Understanding TILOS File Types 
TILOS uses these specific file formats (by extension): 

● .hst - This is a TILOS project template file on which your new projects will 
be based. Using templates with predefined settings and objects can save 
you additional setup work and time. The most important thing in a 
project template is the project coordinates for the job’s time/distance. 

● .hsp - This is the standard TILOS project file format. By default, projects 
are saved to C:\ProgramData\TILOS\TILOS10-Data\Projects\. This path 
can be changed in TILOS by selecting Tools > Options > Configuration 
on the menu. 

● .hsb - This is the file format for a project backup file that you create 
manually. 

Understanding Project Templates 
Standard template defaults include:  

● Pre-defined calendars:  
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○ 5-days per week:  a 5-day calendar with 8 working hours for 
every work day and weekends off work.  

○ Nonstop working:  a 7-day calendar with 24 working hours per 
day.  

● Task templates for easily creating new tasks in a time-distance diagram. 
Task templates save you time by providing default display styles, 
calculation data, costs, and resources. Once a task has been created from 
a template, it can be modified with specific properties and data. 

Project templates can also contain default: 

● Project settings 
● Calendars 
● Views 
● Graphic objects (line, rectangle, parallelogram, etc.) 
● Line styles 
● Auto-text annotations 
● Data field definitions 
● Task calculation values 
● Resource and cost assignments 
● Sub-projects 

If you consistently use the same setting and/or library objects in many projects, 
it will save you a lot of time to set these items up in a project and then save it as 
a template from which to start future projects. 

Review and Edit Project Settings 
As you begin any project, it is important to review and edit any settings that might affect 
your data. 
1. In the Setting for New Project dialog, enter a project name, and review the defaults. 

2. Change the Start (distance) and End (distance) to -200 and 4200 to match the data 
you will insert soon. 

3. For the Start date and End date, click the arrow and select: 

● year 2024, month 5, day 13 through  

● year 2024, month 9, day 13  
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Note: Although these steps will tell you to enter project dates in the international date 
format of YYYY-MM-DD (ISO 8601), what you see in the program interface depends on 
your Windows > Region and Language Settings. screenshots show dates in 
MM-DD-YYYY format. 
Tip: In your own projects, add a little extra time and space around your actual project 
start and end dates and distances to make it easier to work in the graphic views. You 
have just done that here too. 

4. Click Apply to adjust the views and sub-project in the template to the specified 
coordinates.  

5. Save your new project with the new name. 

6. On the menu, select Tools > Options. 

7. In the Time Unit Settings, review the default units for how durations will be displayed 
and edited. Time data can be entered in calendar time or working time.

 

8. Scan the other types of settings on each tab, and close the dialog. 
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Understanding Project Options 
Here are the basic categories of project settings: 
● Project and Project (2) - Define general project properties, such as the ID, 

drawing units, time, and day definitions, sub-projects, and views. 
● Task - Define the options for tasks, for the calculation model, and the display 

of the work rate time unit. 
● Progress - Select entry options for progress.  
● Cost - Define which currency is used as standard and which cost group, e.g., 

for new resources, is used as the standard. 
● Distance - Define which distance units are used as the standard and if an 

equation is used. These settings can be changed later for gaps or data fields. 
● Display - Globally define how lines are displayed for progress, baselines, 

Gantt charts, etc. 
● Functions - Define which additional functions that should be available within 

the program. 
● Snapping - Define how time units for calculations and durations are 

displayed, as well as which distance units are used. Configure a snap grid to 
help graphically position tasks by time and distance intervals. 

● Tokens - Define the general rounding settings for the display of tokens in 
views. 

● Configuration - Define general system settings that affect the program, not 
the specific active *.hsp project file. 
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Review the User Interface (UI) 
Even though reviewing UI out of context can feel fruitless, it will help to spend a few 
minutes understanding the layout of the program. Here are the primary components of 
the UI: 

TILOS Explorer    Menu and Toolbar   Preset Toolbar 

 

  

 

Object Properties pane  Insert Object Toolbar   Working Area 
(Details Toolbar) 
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TILOS Explorer 
The TILOS Explorer is a tree-like, hierarchical structure (like Microsoft® Windows Explorer) that 
shows and gives you access to all of the views, data, objects, and templates in your project. 

 
 

Understanding TILOS Explorer Sections 
The top level categories in the explorer include: 

● Views - This group shows all of the views (time-distance, Gantt chart, list, 
etc.), that you have created for the project. To open a view in the 
Working Area, double-click it or right-click and select Open in 
Active/New Window. 

● Project Data - This group shows all data that is specific to the open 
project, which can include sub-projects, calendars, distance and time axis 
definitions, graphics, and categories (company and work type), and 
contractual project info. 

● Library - This group contains template data and objects that are not 
project-specific; this includes things like tasks, resources, accounts, and 
graphics that can be referenced and used by any project, plus definitions 
of currencies, units, users, filters, and various other data types that can 
be applied to projects. 
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Menu and Toolbar 
The Menu and Toolbar give you access each of the common commands and windows in 
TILOS. 

Insert Object Toolbar 
The Insert Toolbar allows you to add tasks, shapes, text, graphics, legends, time and 
distance diagrams, and WPA point features into the active view.

 

(shown rotated horizontally here) 

Preset Toolbar 
The Preset Toolbar has 3 functions: 

● See and edit default values when you create or select an object. 
● See and edit the template on which a task is based and also set a default summary 

task (if applicable) when you create or select a task. 
● Control and change task data, such as its name, duration, and coordinates when 

you select a task. 

 

Working Area (windows, views, and cells) 
The Working Area is where you will perform operations on plans, schedules, tasks, 
features, and other data. You will find there one or more opened dialog windows. 

You can have one or more windows in the working area, each of which can contain 
different types of views of your project data. Each integrated view consists of cells 
arranged in rows and columns. Two or more cells can be glued together, which means they 
can be combined into one larger cell (as you can in Microsoft Excel). The graphic below 
shows the nesting relationship of windows views, and cells. 

1. Window 
2. View 
3. Cell 
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Creating and Arranging Windows 
To open a new window in the working area, select Window > New Window on 
the menu. In general, the Working Area shows a single window in maximized 
state. If you have multiple windows open, you can organize them by selecting 
Window > Cascade, Tile Horizontal, or Tile Vertical. 

Object Properties pane  
(also known as the Details Toolbar) 

The Object Properties pane shows the properties of any active object (object selected in 
the Working Area). The tabs and properties shown in this pane change depending on what 
is selected. This is where you will edit most of your project data.

 

Create an Integrated View and Configure Cells 
You can create a variety of view types that will enable you to see, select, and edit your 
project data in the most efficient way. The integrated view is the most commonly used view 
type. 

Create a New View  
1. In the TILOS Explorer, right-click Views and select New View. 
2. Enter My Integrated View as the Name for your view. 
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3. Choose Integrated View as the Type, and click Open in New Window. Integrated 
views are the standard for basic scheduling operations because they can contain a 
variety of cell types. 

4. Click the  button at the bottom of your screen to collapse the Object 
Properties pane so you can see the whole view, which should look like this:

 

Create Additional Cells 
Create several other cells to contain different types of views, scales, and data. 

1. Click the outer rectangle (which is a cell also) near the top of the view.  
2. On the menu, select Cells > Row > Add Row to create a row under the cell you 

selected.  
3. Add another cell in a different way by clicking the Cells > Add Row icon on the toolbar. 
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4. Add a new column in a similar way by selecting Cells > Column > Add Column on the 
menu. Your view should now look like this:

 
 

Inserting and Resizing Rows and Columns 
New rows and columns are inserted after the selected row/column. The first and 
last row or column are borders that cannot be removed. If you want insert a row 
or column at the beginning of the cell system, select the border cell. 

Cells within integrated views can be freely resized, as in Microsoft® Excel, by 
changing row and column sizes. To enter row and cell heights and widths 
directly, right-click in the active cell and select Edit View to open a View dialog 
where you can enter row and column sizes in cm or inches (configure this in 
Tools > Options > Project tab). 

 

5. Press Control on your keyboard and roll the mouse wheel to zoom the view in and out. 
Press Shift and roll the mouse wheel to move the view left and right. 

6. Try resizing the columns and rows by clicking-and-dragging any of the small triangles 
along the edge of the view (shown above). Then resize the cells so your view looks like 
the graphic again. 

7. Click the Properties button again, and then the Redock icon in the upper-right 
corner of the floating pane to dock it along the bottom. 

 

Resizing the Working Area 
You can resize the working area by hovering in this area and 
clicking-and-dragging these small handles. 
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To show the full window, you can also click the Properties button in the 
lower-left corner of the screen to float or hide the Object Properties pane. 

 

Zooming In and Out in a Window 
You can zoom in and out of the window by pressing Control and rolling the 
mouse wheel up and down.  

Understanding Cell Numbering 
It is important to understand cell numbering as you will see it when doing a 
variety of things, such as linking cells to each other in master-dependent 
relationships. This is how cells are numbered. 

 
The toolbar also gives you these options: 

● Display Page Width - Click this icon to resize the view scale so that 
the full width is visible. 
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● Display Page Height - Click this icon to resize the view scale so that 
the full height is visible. 

 

Configure a Time-Distance Cell 
This is the cell that will contain your tasks. 

1. Select the larger cell in position 2,3 (3rd column, 4th row) by clicking in it.  
2. Notice that the Cell Settings tab in the Object Properties pane at the bottom of your 

screen shows the cell position number (this pane is where you will configure any 
selected object). 

 

3. Next to the Cell type field, click the Cell Wizard icon. Using wizards is the easiest 
way to configure cells and other types of objects in TILOS. 

4. In the Cell type list, select Time-Distance Cell, and click OK. 
5. In the Sub-Project Settings dialog, check the Default Sub-Project box for Project 1.  

 
 

Using Sub-Projects 
Each TILOS project file contains one default sub-project (needed in order to 
create task data). To organize the work on more complex construction projects, 
you may find it helpful to separate the work into multiple, additional 
sub-projects, each of which contains related tasks. Alternately, each section of a 
construction project can be defined as a sub-project and displayed in a view’s 
cell. 
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6. Click OK and answer Yes to adjust the view range to the project extents. 
7. Accept the defaults in the Adjust View Range dialog and click OK to adjust the time 

and distance range of the cell and apply a time axis by week. The view range is set by 
the projects coordinates, but may be changed at any time to show only a certain 
portion of the project.  

 
8. In the Axis list on the Cell Settings tab, select/confirm Time vertical to align the 

calendar along the Y axis; distance will be aligned along the X axis.  

 
9. Click in your new time-distance cell. Now your view should look like this, and more 

property tabs will be visible. The colored bars across the cell denote weekend time 
based on the default calendar for the project. 
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10. Click the Display tab, and confirm these calendar and display options for the selected 

time-distance cell of the view.  

 
 

Configuring a Calendar Display Based on Project Duration 
On your projects, use Per Day for long projects that span months or years. The 
task lines will not break within the daily working time patterns (e.g., working 
breaks at night).  
Use Exactly for short and detailed views that span only 2 or 3 days. The task line 
gets broken with the daily working time patterns (broken for the night breaks). 
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13. In the same section, click Settings and and check the Collapse Day Definition box in 
the Weekend row to collapse the weekend time from the time axis.

 

14. Click OK. The horizontal bars for the weekends you saw before are now hidden. 

Setting Cell Properties 
Cells organize and segregate different types in a view. There are many different cell 
types. including: 

● Time-distance cell: Used to show a time-distance diagram with tasks that 
span a time axis and a distance axis. 

● Time cell: Used to show time-related data only, such as time scales.  
● Distance cell: Used to show distance related data only, such as distance 

sketches, diagrams, or scales.  
● Gantt chart cell (Time): Used to show project data as a Gantt chart within a 

view. The axis shows time, like used in Gantt charts. 

These other cell types are used for more advanced scenarios not covered in this 
guide: 

● Gantt chart cell (Distance): Used to show project data as a bar chart within 
a view. The axis shows location. 

● Distance cell with Y-Axis (2-axis cell): Used for work phase planning with 
the Work Phase Assistant. This call can host an area map and point and line 
features. 

● Graphic cell: Used to show graphic data only, such as company logos and 
stamps, in border cells.  

● Mass Haulage Diagram: Used to show mass haulage data (mass areas and 
mass haulages) with cut and fill areas. 

● Dashboard: This cell type is used to show a dashboard with task values in a 
table.  

● Dashboard (allocations): Used to show a dashboard for resource and cost 
data.  
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Adding Content to a Cell 
To display existing cell content in a cell, select a cell type and the requested cell 
content. 

To create a NEW cell content (chart objects), click the Cell wizard icon. 

 

Based on cell type, different items are offered. In this way, planning is independent 
from the presentation. Within one project, you can have different views (days 
planning mode/ hours planning mode and partial views for selected distance 
sections). The system‘s flexibility is practically unlimited.  

Setting View Ranges 
For each cell, you can set the visible area of the project in the Cell Settings tab:

 

The scale is calculated by the width of the cell and the cell ranges. If you have a 
complex cell system and change the range of the main central time-distance cell, 
then you also need to adjust the surrounding cells.  

Configure Two Distance Cells 
These are the cells that will contain a distance graphic of the project site and a distance 
scale, respectively. 
1. Click in the smaller cell (2,1) two cells above the one you just configured. 

2. On the Cell Settings tab in the Object Properties pane, click the Cell Wizard icon 
again.  

3. In the Cell type list, select Distance Cell, and click OK. 

 20

  



 

4. Confirm that the Display EXISTING Cell content (distance-related) option is 
selected. 

5. Select Distance drawing in the Cell content list, and click OK. 
6. Click OK in the Select Master Cell dialog to use the time-distance cell as the Distance 

master cell for this new distance cell. Since your view contains only one time-distance 
cell, this master cell is pre-selected. 

 

Configuring Master and Dependent Cells 
Master cells provide the time and/or distance scales to dependent cells, depending 
on the cell type. The master can be time-distance or Gantt chart cells in the same row 
or column as the dependent cell. 
A master cell provides the range in time or/and distance to the dependent cell, 
depending on that cell’s type.  
If a cell has a master cell defined, its coordinates cannot be edited independently; 
their scale is taken from the master cell.  

 

7. Click the cell (2,2) just above the main time-distance cell to select it. 

8. Click the  Cell wizard icon on the Cell settings tab. 
9. Select Distance Cell and click OK. 
10. Choose Create and display NEW cell content and check the Insert distance scale 

box. 
11. Shorten the name to Distance Scale Cell and click OK. 
12. In the Distance master cell list, select the previously defined time-distance cell 

<(2,3)>.  

Configure a Time Cell 
This is the cell that will contain month, week, and day time scales. 

 

1. Click the cell to the left of the main cell (1,3) to select it. 
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2. On the Cell Settings tab, click the Cell Wizard icon again, and choose Time 
cell, and click OK. 

3. Select Create and Display NEW Cell content, check the Insert times scale box.

 
4. Shorten the name to just Time Scale Cell, and click OK. 
5. In the Select Master Cell dialog, select/confirm the previously defined 

time-distance cell <(2,3)> as the Time master cell and click OK. 
6. Your time cell should look like this, with one scale already in it:

 

Add Time and Distance Scales to Cells 

Now prepare one of the vertical cells to display additional time scales, and prepare a 
horizontal cell to display a distance scale. These will give chronological and spatial context 
to the tasks you will create soon. 

Add Two More Time Scales 
1. Select the time cell with the scale and click the Define Time Scales tab. One label 

{Calendar week} has already been created. 
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2. Click the  Add Line icon to insert a new line.

 
3. Set the properties (except for the Label) shown below in the Time Scale Line 

Properties dialog. 

 
Reminder: In these screenshots, the MM/DD/YYYY date format is used, so 12/9/2020 
would be the 9th of December, not the 12th of September (as it would be in some parts 
of the world). 

4. For the Label, delete {Calendar week}, and press F8 to open the time tokens list. 
5. Select Time units > Month (mmm) as the label. This will create a second time scale 

with a three-character label for the months.  
6. Click OK to close the dialog. 
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Understanding Tokens 
Tokens are used to insert and control the display of various types of data, such as 
date, distance, time, scales, duration, etc. 

 
Wherever you are in a text field with a value in curly brackets (e.g., {Calendar week}) 
you can press F8 to access a list of applicable tokens that can be used there. In 
addition, you can define your own custom tokens for unique data types not 
represented in the list. 

 

7. Use steps 1- 6 above to create a time scale for Time units > Day (dd) with a horizontal 
Rotation. 

8. Back on the Define Time Scales tab, double-click the first cell (Name for Calendar 
week) and enter the name Week.  

9. Then select the Month row and click the  Move Up icon to move it to the top so 
the scale looks like this. 
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Troubleshooting Scale Labels 
If your scale labels ever look like this (dots instead of characters), it means that there is 
not enough room to display the label text.  

 

To fix this, you can: 

● Widen the cell by clicking-and-dragging the arrows along the edge of the view or  
● Select the scale cell, click the Define Time Scales tab, double-click the name of 

the label that is not appearing, and make sure that Rotation is set correctly in 
the Text Display Group. 

● Make sure the unit is set to match the label, e.g., if the label is Month, the unit 
should be Month. 

● Edit the token in the dialog mentioned above to be shorter, e.g., change {Day 
{dddd}} to {Day {d}} where d is the number of characters allowed in the label 
(which matches Microsoft Excel). 

○ d =3 
○ dd = 03 
○ ddd = Mo 
○ dddd = Monday 
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Add a Distance Scale 
1. Click the distance cell (2,2) above the master time-distance cell again.

 
2. Click the Define Distance Scales tab. One {Distance (base unit)} label has already been 

created. 

 
3. Click in the row and type Kilometers. 
4. Double-click the row to open the Distance Scale Line Properties dialog.  

The Label is already populated with the {Distance (base unit)} token, which is 
dependent on the selected unit, e.g., 1000 m or 1000 km, depending on the distance 
unit you are using. 

5. Delete this entry, press F8, and select Distance > m.  
6. Set the Interval to 1000, which means 1 line will be drawn in the cell every 1000 m.  
7. Click OK and the scale will look like this.

 

7. Click the  Add Line icon to create an additional distance scale. 
8. Add Meters in Kilometers for the Name. 
9. Delete the Label, press F8, and select Distance > m in km. 
10. Set the Interval to 100, which means 1 line will be drawn every 100 m. 
11. For the Distance unit, select m in km, which means the fraction part of meter in 1 

kilometer. 
12. Set the Text Display > Size to 6, and the Rotation to Vertical. 
13. Click OK. The distance scale should look like this: 
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If it does not, confirm that your values match these and fix any that do not. 

 

 

Troubleshooting Scale Visibility 

If the scale you add does not appear in the cell, try these things: 
● Drag the cell’s sizing triangles to expand the cell’s height and/or width. 
● On the Cell Settings tab for the master (usually time-distance) cell, make 

sure that the End distance value matches/exceeds the length of the scale. 

● Also on the aforementioned tab, click the Adjust View Range icon 
and check the Apply Distance Axis box. 

 

Add Station Points 
To assist with positioning tasks on the distance axis, also define station points that you can 
add to the distance scale cell. You can also import/export such locations via your computer 
clipboard. 
 

Importing Distance Grid Data 
Grid data can also be imported using the Import and Column Setup button. For 
example, the data for this grid is stored in a Microsoft Excel file called Road 
map.xls in the Addon folder of application data of your TILOS installation.  
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1. In TILOS Explorer, expand Project Data > Distance Axis Definitions, and double-click 

Distance Profiles. 

2. Click the  Add Line icon to add a new row. 
3. Double-click the new row in the chart and enter the Name as Station Points. 
4. Confirm that the Display in distance drop-downs box is checked so that the station 

points you add will will be selectable as coordinates for tasks. 

5. Click the  Add Line icon in the dialog seven times so you can add several station 
points to the list. 

6. In the station point rows, enter these values: 

 
Tip: When selecting types in the list, you can type the type the first few letters to jump 
to the entry. 

7. Click OK to close the dialog. 

Add the Station Point Lines as an Irregular Scale with Text 
Now return to the distance cell to add the scale for these station points as an irregular 
(non-linear) distance scale. 

1. In TILOS Explorer, return to Views > Integrated View and double-click My 
Integrated View. 

2. Select the distance cell with scales and click the Define Distance Scales tab again.  
3. Add a new row to re-open the Distance Scale Line Properties dialog. 
4. In the Name field, enter Station Points. 
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5. Delete {Distance (base unit)} from the Label field, press F8, and select Distance 
Profile Tokens > Name. 

6. Set the Height = 1.2. 
7. Set the Alignment to Bottom. 
8. Set the Rotation to Vertical. 
9. Set the Text Display > Size to 6. 
10. In the Additional Options group, select/confirm the Distance profile option, and 

choose Station points in the list of profiles.  
11. Check the Display only profile values box to hide regular values. 

  

 29

  



 

12. Click OK. The distance scale in the time-distance cell should look like this:

 
 

Inserting Charts/Scales that are Smaller than the Cell 
The scales you have created so far are based on chart objects that covers an 
entire cell. You can also insert smaller charts directly into cells, as you would 
other graphics. 

Check Your Cell Types 
1. Confirm that you have laid out your cells properly by clicking the Display View Map 

icon on the toolbar. 

     
In this image, the yellow arrows point from the dependent cells to their master cell.   

2. Click the icon again when you are done to return to the standard view. 

Insert and Scale a Distance Graphic 

To give context to your project data, add a distance graphic (e.g., a sketch showing the job 
site). You have already defined the cell above the distance scale as a distance cell so you 
can add a distance graphic to it. 
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Insert a graphic 
1. Select the distance cell (2,1) near the top of the view. 
2. On the Insert Object Toolbar (along the left side of the active window), click the  

Insert Graphic Object icon. 
3. On the Preset Toolbar, select Horizontal in the Figure scaling list. This ensures that 

on changing distance scales or showing only part of the project, the graphic will always 
be adjusted. 

 

4. In the cell, click-and-drag to draw a rectangle where you want to insert the graphic. You 
do not have to be exact because you will adjust the image with other tools.

 
5. In the Insert Graphic Object dialog, select Insert Graphic from File to import a file, 

and click OK. 

 
 

Dragging-and-Dropping Graphics 
You can also insert graphics by dragging-and-dropping them from a graphic 
library to cells in the same way you can insert them into the Library from 
Windows Explorer. 
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6. Browse to the TILOS data folder and select the Road map.jpg file. Refer to Tools > 
Options > Configuration tab to find out where your data installation is (the default is 
C:\ProgramData\TILOS\TILOS102-Data\AddOn).

 
7. In the Object Properties pane, click the Position tab, and check the Keep 

proportions box to ensure that your graphic retains its aspect ratio. The size of the 
graphic is controlled by the distance scale, based on the Horizontal scale setting after 
insertion. 

If you accidentally deselect the graphic, you can reselect it by right-clicking and then 
clicking the blue square in the center.

 

Synchronize the Graphic with a Scale 
1. With the graphic selected, select Distance in the Scaling list on the Position tab. 
2. Click Adjust position, read the message, and click Close. 
3. Zoom in (Control + mouse wheel forward) if needed, position the cursor at Miles 

street, and click-and-drag a rectangle (guided by the ruler-band line) to Jefferson 
street. 
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4. In the Adjust Figure Position dialog, check the X box and enter the station numbers 
from both streets (as shown in drawing) for the Start (distance) and End (distance).

 
5. Click OK to adjust the graphic. This operation changes both the graphic’s horizontal 

scale and height, so you may have to adjust the cell height as well.

 
6. Notice how the streets/crossings and river/creek now line up.  

Add a Distance Grid to the Graphic Cell 
Overlay your map graphic with distance grid lines.  

1. Click in the cell with the graphic to select the cell. 
2. Click the Grids tab in the Object Properties pane.

 
3. In the Distance Grid section, check the Display box to make the grid visible. 
4. For the Distance Grid, select Every 1000 / Location Points. The grid appears behind 

the map graphic. 
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5. Select Top Text Layer in the Layer list to bring the grid forward in the graphical ‘stack 
order’. 

6. Select the Road map graphic and change the layer to Standard layer. The same grid as 
shown in the main cell is now visible in the distance cell. 

 

 

Setting the Layer for Objects and Ordering Layers in a Cell 
Layers control the visibility and selectability of data in views. Layers are like 
transparent sheets placed one on top of another in a graphical ‘stack order’; the 
upper-most/top layer is in the foreground. To change the visibility and/or order 
of objects on a layer and layers in a cell: 

1. Pick each object/piece of data in the cell and make sure it is assigned to 
an appropriate layer in the Layer list. 

 
2. Select the cell border and click the Layers tab. 
3. Check boxes to control the visibility and selectability of the data one each 

layer as needed. 
4. Use the blue buttons on the right side of the pane to: 

○ Move Up/Down - Move selected layers in the list (stack order) 
to bring some objects to the foreground and push others to the 
background. 

○ Synchronize Layers - Open a dialog that enables you to: 
i. Get the order of the layers from your Library. 
ii. Set all cell layers in the view like the current cell. 
iii. Set Visible and Printable for all non-system layers. 
iv. Toggle all visible layers to be printable. 
v. Toggle all printable layers to be visible. 
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○ Display Only Used Layers - Hide layers that are not in use in 

the selected cell.  

 

Add Additional Lines to the Grid 
1. Deselect the graphic and select the distance cell that contains it again. 

2. Click the  Edit icon in the Distance Grid section. 

3. Add another grid line by clicking the  Add Line icon.

 
4. Press F8 and select Distance Profile Tokens > Name for the Text expression. This 

will print the name of the grid line. 
5. Confirm that the Visible box is checked. 
6. Change the Line color to orange. 
7. Confirm the Distance profile option, and select the Station points profile in the list. 
8. Check the Display only profile values box and the Color lines by sector color box. 

The colors are defined using the color of the sector type (from the Library) according to 
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the sector type in the Distance profile > Station Points.

 
9. Click OK and OK again to see this additional grid in the distance cell.

 

You can control the display of grids for each cell individually by checking/unchecking 
the Display boxes on the Grids tab in the Properties pane.  
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Insert Tasks 
Tasks are at the center of building a project schedule. Tasks can be entered into a 
time-distance cell, entered in a Gantt chart cell (text or bars panel), or entered directly into 
the Task List for a sub-project. 

Inserting Tasks 

● Calendars: If you are using a default 5-days per week calendar, the 
task’s line is automatically broken on weekends and holidays (no work), 
indicating  no work progress. This can be changed using the display 
settings for the cell. Select the cell. In the Object Properties pane at the 
bottom of the screen, click the Display tab, and change the Calendar 
option.  

● Snapping:  When inserting tasks, you can also use snapping to accurately 
place the start and end points based on constant time and/or distance 
intervals, as well as specified grid lines. On the Main Menu, select Tools 
> Options > Snapping tab. 

● Naming:  Enter the Name of the task in the Object Properties pane > 
Details tab (or on the Preset Toolbar). 

 

● Layer:  Every task has a Layer assignment. Layers determine both the 
depth arrangement (stack order), visibility, and selectability of objects. 
The layer assignment for new tasks is the default layer if no layer was 
defined in the library for the template. The layer can be changed on the 
Object Properties pane > Details tab. 

● Appearance:  If you want to change a line’s presentation, select the 
Display tab in Object Properties pane. 

 

Of course, many other task properties can be changed on the Object Properties 
pane, including: 
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● Sub-project:  Every task is created as part of a sub-project. The 
sub-project assignment for new tasks is the default sub-project.  

● Figures:  Changing the figures for the task does not affect the data in the 
template, although the task can still be linked to the template. The 
different task types are explained in the appendix. 

● Calculations: On the Calculation tab, every task may have the Quantity 
or Work rate values assigned.  

Inserting the same task or object repeatedly (repetitive entry) 

To add multiple tasks or objects one after the other, click the desired insertion 

tool icon (e.g., Insert Task) and then the  Lock Insert Tool icon to keep the 
active insertion type active. 

To change the default task template, press Escape to deselect the newly added 
task. The Preset Toolbar will then show the list of task templates. 

● Drag and Drop Task Types to Create a Template Type and/or a 
Schedule  - You can quickly create a schedule by dragging and dropping 
task types from the Task Templates library to a Gantt chart. When you 
drop the task type, a task is created with its start date at the location of 
your cursor. The reverse is also true: you can drag a unique task from a 
Gantt chart to the Task Template library to create a new task type 
template. 

● Add a New Task using the Insert Key - You can add a task into a Gantt 
chart by selecting a task template, picking an existing row in the chart, 
and pressing the Insert keyboard key. The new task is created (using the 
selected template) above the selected task in the chart (as it is in MS 
Project). 

● Work with Task List and Time Distance View in Parallel - The 
interaction between a time-distance view and a task list includes a Task 
List tab beneath the TILOS Explorer. When you are in a time-distance cell, 
you can click the tab to see a list of all visible tasks in the cell (with the 
same filter applied). When you select tasks in the list, the same ones are 
then selected in the view. If the task is outside the extents of the view's 
visible area, you are prompted to change the extents. If the task is within 
the extents, the view is scrolled to it. These features make it easier to 
select tasks and change them in the time-distance view using the task list. 

● Specify a Default Summary Task - You can select a default summary 
task for the selected task template in the Preset toolbar so that each task 
is automatically associated with a summary when it is created. 
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In this section, you will insert these tasks:  (you may want to print this for reference) 

 

Task  Task Template  D/M/Y Dates   M/D/Y Dates  Distance 

1  Earthworks > Topsoil stripping  20/5/24 - 14/6/24  5/20/24 - 6/14/24  2700 - 0 

2  Earthworks > Soil removal  31/5/24 - 3/7/24  5/31/24 - 7/3/24  1700 - 0 

3  Earthworks > Soil installation  31/5/24 - 3/7/24  5/31/24 - 7/3/24  1700 - 2700 

2  Earthworks > Soil removal  31/5/24 - 3/7/24  5/31/24 - 7/3/24  1700 - 0 

4  Earthworks > Topsoil stripping  17/6/24 - 1/7/24  6/17/24 - 7/1/24  2700 - 4000 

5  Canalisation > Culvert  20/5/24 - 17/6/24  5/20/24 - 6/17/24  2650 - 2750 

  Canalisation > Culvert >  River Bed  20/5/24 - 28/5/24  5/20/24 - 5/28/24  2650 - 2750 

  Canalisation > Culvert > Walls  29/5/24 - 6/6/24  5/29/24 - 6/6/24  2650 - 2750 

  Canalisation > Culvert > Deck  7/6/24 - 17/6/24  6/7/24 - 6/17/24  2650 - 2750 

6  Canalisation > Trench opening  3/7/24 - 12/8/24  7/3/24 - 8/12/24  2700 - 0 

7  Canalisation > Pipe laying  5/7/24 - 12/8/24  7/5/24 - 8/12/24  2700 - 0 

8  Canalisation > Trench opening  12/8/24 - 2/9/24  8/1/242 - 9/2/24  2700 - 4000 

9  Canalisation > Pipe laying  14/8/24 - 2/9/24  8/14/24 - 9/2/24  2700 - 4000 
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To look like this: 
 

 
 

Before you add tasks to your project set up the task ID scheme. 

1. On the toolbar, click the Options icon, and select the Task tab. 
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2. Next to the Task ID Format field, click the Generate ID icon. 

 
3. Set these values in the Set Task ID dialog so the tasks you add next will be numbered  

1 through 9. 

 
4. Click OK and OK again to close the Options dialog. 
5. Select the time-distance cell.   
6. On the Insert Object Toolbar, click the  Insert Task icon. 
7. On the Preset Toolbar, select Earthworks > Topsoil stripping as the Task template 

to use for the new task. This can also be set by clicking a task template in the TILOS 
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Explorer > Library > Task Libraries > Task Templates before you insert a task.  

 

 

Creating New Tasks Types “On-the-fly” 

If the library does not contain the type of task you need, you can always select 
<None> in the Task template list to create a task without using a template (or use 
any other template and change the task individually later). 

 

8. Insert Task 1 - Topsoil Stripping. 
a. Place your cursor over the task’s starting point near the intersection of 

May 20th on the time axis and and 2700 (River) on the distance axis. 

 

b. Click-and-drag from right to left to draw a line to the task’s end position 
near the intersection of June 14th on the time axis and and 0 on the 
distance axis. 
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Tip: You can also look at the lower-right corner of the TILOS window to 
cursor’s cell coordinates. 

 

‘Drawing’ Tasks 
It is important to note that whether a task is drawn from left-to-right or from 
right-to-left determines the start and end coordinates; the end date of a task must 
always later than the beginning of the task. If you need to change the direction of the 
task afterward, click Change of direction on the Coordinates tab. 
When inserting tasks, do not worry too much about start and end dates. You can 
draw the tasks  roughly according to a graphical plan and then edit later with exact 
dates and coordinates. 
The dates in the table below are taken after rescheduling the final project, so do not 
be concerned if they differ from your input. The task templates to select in the preset 
toolbar can be located in different subdirectories (e.g. Earthworks and Canalisation). 

 

 

c. Click the Coordinates tab, and adjust (if needed) the Start and End dates 
and coordinate to match your targeted values (May 20 - June 14 and meters 
2700 - 0). 
When you  release, the task stays selected and can be edited in the Object 
Properties pane. 

d. Click the Calculation tab in the Object Properties pane. 
e. Enter these values for Task 1: 
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6. Insert Task 2 - Soil removal in the same way using data from the chart on page 39. 
When you insert tasks in these steps, remember to check the task template on the 
Preset Toolbar first, and adjust the dates and start and end locations on the 
Coordinates tab afterwards. 

a. On the Calculation tab, enter these values for Task 2: 

 

7. Insert Task 3 from the chart as well. 
a. Click the Details tab and set the Type to Hammock task. 
b. Select the Categories & Structure tab, and check/confirm the Keep own 

Distance Coordinates box to ensure that the hammock does NOT take the 
distance coordinates from the assigned tasks; it keeps its own location. 

c. Click the  Add Task to Hammock icon next to the Tasks in Hammock 
grid and select Soil removal in the first row of the Task column. Your task’s 
ID number may differ if you have created other tasks before this.

 
The hammock task monitors Task 2 - Soil removal task.  

d. On the Calculations tab, enter these values for Task 3: 
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Understanding Summary and Hammock Task Types 
Summary and hammock tasks enable you to associate individual tasks into groups. 
The primary difference between summary and hammock tasks is that all tasks 
assigned to a hammock task keep their placement in the project structure and copies 
of the tasks are created one level below the hammock task. Changes in these tasks 
are reflected to their copies and vice versa. Tasks inside a hammock task should only 
be deleted if the original task should also be deleted, which is done automatically. 
Otherwise, with the task selected you can simply remove tasks to the right of the 
table on the Categories & Structure tab. 
Summary Task 

● A summary task summarizes individual tasks within a sub-project. 
● The summary task displays the total distance and time range of all sub tasks. 
● Summary tasks can be hidden or shown. 
● You can either display the summary task with task details (opened) or the 

summary task only (closed). 
● The display of a closed summary task depends on the chosen task template, 

e.g. rectangle. 
● Costs and resources can be allocated to a summary task. 

Hammock Task 
● Using hammock tasks, you can create relations to tasks in different 

sub-projects. 
● The display of a hammock task depends on the chosen task template. 
● Costs and resources can be allocated to a hammock task. 

 

8. Insert Task 4 by selecting the coordinate at the river from the Station points distance 
profile: 

a. Draw the task in the general area shown in the chart. 
b. On the Coordinate tab, click the arrow next to the Start Distance. 
c. Expand the Station points group. 
d. Select River to start the task at 2700. Now if the River station point is 

moved, the task will be adjusted accordingly. 
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e. On the Calculations tab, enter these values for Task 4: 

 

The quantity shown on the Calculation tab is smaller than for Task 1 - Topsoil 
Stripping because the distance is shorter.  

9. Insert Task 5 as a summary task for a culvert. As a summary task, it will contain three 
sub-tasks linked to each other. 

a. In the TILOS Explorer, expand Library > Task Libraries > Task Templates 
> Canalisation > Culvert. Review how Culvert has three available sub-tasks: 
Deck, River bed, and Walls. 

b. Before you insert the task, select Canalisation > Culvert on the Preset 
Toolbar. 

c. Draw and adjust the task’s coordinates as shown in the chart. 
d. On the Details tab, set the Type to Summary task. 
e. On the Calculations tab, confirm these values for Task 5: 
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f. Create the three subtasks using the values from the chart. 

 
g. Press Control and select each of the sub-tasks you just created. 
h. In the Object Properties pane, click the Categories & Structure tab.  
i. On the right side, select Culvert in the Parent task list. 

10. Insert Task 6 and Task 7 using the Insert Task Group function. 

a. Click the  Insert Task Group icon on the Insert Object Toolbar. 
b. Draw a box approximately when/where the tasks will be performed.

 
c. In the Insert Task Group dialog, select Canalisation as the Task group. 
d. In the Distance coordinates > Method list, select by coordinates. 
e. Enter 2700 and 0 for the Start and End coordinates. 
f. Enter the Time coordinates > Start date from the chart (7/3). Do not worry 

that Tasks 6 and 7 have different start dates; this difference is defined in the 
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task group template being used.

 

g. Click OK. Using this method, you have created two tasks at once. 

h. On the Calculations tab, enter these values for Task 6: 

 

i. On the Calculations tab, enter these values for Task 7: 

 

11. Create Task 8 - Trench Opening and Task 9 - Pipe Laying by copying previous tasks. 
a. The previous tasks should still be selected, but if not press Control and 

select Task 6 and Task 7. 
b. Right-click and select Task Creation > Copy Task.  
c. Enter 2700 and 4000 as the Start and End coordinates for the two 

additional tasks. 
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d. Select August 1 as the Destination date > Start.

 
e. Click OK, and check the tasks in your view against the view on page 37 to 

make sure your view matches the intended plan. 
f. On the Calculations tab, enter these values for Task 8: 

 

g. On the Calculations tab, enter these values for  Task 9: 
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Link the Tasks to Each Other 
If you have defined a sequence of tasks and you want its logical dependencies to be kept 
even if one of the tasks is moved, you can ensure that by defining task links. 

 

Automatically Calculating a Successor’s End Date 
Linking tasks so they have the same duration and end date - When using a 
Finish to Finish link between two tasks, you can base one or more successor task 
end dates on their predecessor task’s end date. Enable the Calculate successor end 
date option for the link when you want a master task to control when parallel tasks 
end; the other tasks will finish at the same time as the master task. If you change the 
duration of one task and then reschedule, the second task is changed in duration to 
meet the same end date as the predecessor. You can also add lead or lag times to 
make the successor to make it end before or after the end of the predecessor. 
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Now you will create these links between tasks: 

#  Predecessor (from task)  Successor (to task)  Link Type  Lag 

1  Task 1 - Topsoil Stripping  Task 4 - Topsoil Stripping  Finish to Start  0 

2  Task 2 -Soil Removal  Task 6 - Trench Opening  Finish to Start  0 

3  Sub-task - Walls  Sub-task - Deck  Finish to Start  0 

4  Sub-task - River Bed  Sub-task - Walls  Finish to Start  0 

5  Task 1 - Topsoil Stripping  Task 5 - Culvert  Start to Start  0 

6  Task 6 - Trench Opening  Task 8 - Trench Opening  Finish to Start  0 

7  Task 6 - Trench Opening  Task 7 -  Pipe Laying  Start to Start  2 days 

8  Task 8 - Trench Opening  Task 9 - Pipe Laying  Start to Start  2 days 

9  Task 1 - Topsoil Stripping  Task 2 - Soil Removal  Start to Start  400 m 
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1. Link Task 1 to Task 4. 
a. Select Task 1 - Topsoil Stripping in the view. 
b. Click-and-drag the red arrow on the lower-left end (finish) to the top-left 

corner (start) of Task 4 - Topsoil Stripping. Release when you see the 
anchor symbol appear over the target task. This will place the link at the 
start of the target summary task to create a Finish to Start link. 
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5. Link Task 2 to Task 6. 

a. Select Task 2 - Soil removal and create a link by clicking-and-dragging the 
link arrow from the lower-left end (finish) of Task 2 - Soil removal to the 
upper-right end (start) of Task 6 - Trench Opening.  

6. Use a different method to link Task 1 to Task 5. 
a. Right-click Task 1 - Topsoil stripping and select Create Successor in the 

context menu.  
b. In the Successor list, select Task 5 - Culvert. 
c. In the New Link dialog, select Start to Start as the Link type. 

7. Link Task 6 - Trench opening to Task 8 - Trench opening with a Finish to Start link. 
Make sure to choose Working time of predecessor in the Calculate lag by list. 

8. Link Task 6 - Trench opening to Task 7 - Pipe laying with a Start to Start link. 
a. On the Link tab, enter 2.00 in the Lag field to delay the start of task the 

successor task by 2 days.  

 

9. Link Task 8 - Trench opening to Task 9 - Pipe laying with a Start to Start link. 
a. Add a lag of 2 days in the same way as above 

10. Link Task 1 - Topsoil stripping to Task 2 - Soil removal with a Start to Start link. 
a. In the Calculate lag by list, select Distance to successor. 

 
b. Enter 400 m for the Distance lag value. This keeps the production sequence 

between the two tasks always at a distance of 400 m. 
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Defining Task Leads and Lags 
The ability to define leads and lags by distance is a feature unique to TILOS! 
When you create a link, it always uses the same settings (such as lead or lag) as the 
last link created (not the link changed just prior). 

 

11. Select the time-distance cell, and click the  Reschedule tasks icon or press F9 to 
reschedule. The reschedule operation recalculate the tasks’ time data. Review the plan 
so you can see the result of adding the lags.  

 

Linking Tasks 
If tasks are very close to one another, the neighbouring tasks may get linked to one 
another, when dropping link end with the mouse. In this case check the links 
predecessor and successor by selecting the link and check its attributes in the Object 
Properties pane. 
You may also create links by: 

● Select a task and select the Links & Constraints tab in the Object Properties 
pane. Here you may create a predecessor or a successor for the task. 

● Select the View Link list (If no Link exists, create one with clicking the right 
mouse button on View > New View, choose Link list as View type and name 
the list, a folder named Link List is created in the Explorer containing your 

newly created link list), the list is shown in the main window, use  symbol 
to create a new link, choose predecessor and successor.  

Link Categories 
This option allows you to assign links to a category, by which the shape and color of 
the link is defined. Link category also allows you to exclude tasks from reschedule. 

● Alternatively, you may add or edit links on:  
o The Links & Constraints tab, displayed when you select a task in the 

view. You may define here the predecessor and successor tasks. 
o The links list for the sub-project. 
o Select 2 or more tasks and then use the Right Mouse Button function: 

Link unlinked tasks. 
● On the Links & Constraints tab you may also set the constraints. 

Constraints are tasks’ fixed Start and End dates (times). They will be adjusted 
while rescheduling only within the set constraints.  

● Unlinked tasks do not change their coordinates when you use the 
reschedule algorithm. They only interact with the report date. All 
unperformed tasks are moved beyond the report date. See more information 
at: Tools > Options - Task Tab. 
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Creating a Link List 
You may find it helpful to create a list of links in your project by: 

1. Right-click Views in the TILOS Explorer and select New View. 
2. Name the view Link List. 
3. Select Link List as the Type of view. 
4. Click Open in New Window. 

 

View Tasks and Links in a Gantt Chart  
Project data (like tasks and links) can also be viewed as a Gantt chart (schedule bar chart). 

1. In TILOS Explorer, expand Views > Gantt Chart (time), and double-click the Gantt 
View (default) to open it in the active view. 

  

2. Review the layout of the chart and return to the Integrated View > Time Distance View 
when you are done. 

 

Using Gantt Charts 
To create a new Gantt chart, right-click Views in the explorer, select New View, and 
set the Type of view to Gantt Chart (time) or Gantt Chart (location).  
In the subsequent Sub-Project Settings dialog, you can select the sub-projects you 
want to see in the Gantt chart. You can create new tasks in a Gantt chart in the same 
way as in a time-distance diagram. 
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Label the Tasks 
Now you will add additional text labels (annotations) at the start, middle, end of the tasks 
based on text tokens. In the steps below, you will see the drawing method for adding a text 
annotation to the Topsoil stripping task. There are task templates that are already 
annotated with the information „NAME, Quantity, Quantity Unit“ ( e.g. Topsoil Stripping, 
21600 m²) in the TILOS library. In the following, you will add additional information. 
 

Annotating tasks 
In addition to tasks, you can also insert independent graphic objects into a plan for 
illustration and explanation. 
 
In TILOS, the easiest way to insert task annotations is to right-click a task, and select 
Add Task Annotation. 

Tip for Annotations 
When an object or task is selected, you can edit its settings in the Object Properties 
Pane. 

Text Fields vs. Annotations 
Text fields are independent of any object. Annotations are tied to objects and get the 
text they display from the objects by using tokens. 

 

1. Right-click Task 1 - Topsoil stripping and select Add Task Annotation. 
2. Click OK to close the dialog. 
3. On the Text field tab in the Object Properties pane, delete the word text and press 

F8 to see the available text tokens. 
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4. Select Task Tokens > Date > Start > Schedule > Start.Date.Schedule.dd.mm.yy to 
annotate the scheduled start date in the DD.MM.YY format. 

 
5. Add any other tokens you need to give information on the task. For example, you could 

add: 
● Name 
● Distance 
● Quantity 
●  % complete 

You can also enter non-token (free text) in annotations. 

6. On the Text Field tab, also: 
a. Check the Apply slope of task box to align the annotation to the task’s 

angle. 
b. Uncheck the Manual size box so the program will calculate an appropriate 

size for the text box.

 
7. Click back in the view to see the text change. Now that you have annotated the start 

date of your task, you can fill in more and different information in the same text field 
by entering a space and selecting one or more additional tokens. 
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8. If necessary click-and-drag the center handle to move the annotation closer to the line.

 
9. Repeat these steps to add, connect, and edit annotations to the remaining tasks. 

Change the Calendar 
These steps will give you a generic idea of how you can change the calendar in this project 
as well as in your own projects. If you reschedule after making calendar changes, you will 
see the effects.  

1. In TILOS Explorer, expand Project Data, right-click Calendars, and select New 
Calendar.

 
2. Press Control and pick multiple days to select them. You can also click-and-drag a box 

around adjacent days to select them. 
3. Select a Day definition in the Day Definition list. This definition is assigned to all of 

the selected days. 
4. Enter exceptions... 
5. Select Clear Exception to remove the special settings from that day. Exceptions are 

printed in the color set in the day definition. 
6. Click OK. The tasks and views are adjusted to the new calendar settings. 
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Using Calendars  
Calendars are used for:  

● Controlling the presentation colors and patterns of views 
● Calculating the duration of tasks based on working time and non-working 

time. Every task can use one calendar. Default calendars for new tasks are set 
in Tools > Options > Project (2).  

● If you select Tools > Options > Project tab, and check the Advanced 
calendar interface box, you can add more complex work definitions. 
Without this option selected, you will see a Week definition tab in the 
calendar dialog. With this option enabled, you will see a Periods tab. 

A calendar consists of: 

● Periods: This tab lets you set up more complex work definitions like 
periodically changing working times in winter and summer, or a 14 day shift 
with 10 days working and 4 days free. 
Note: This is the recommended method; using the non-advanced/week 
definition calendar could lead to problems with the start day of the week. 

Or  

● Week definitions: In the simple calendar definition, you set up which days of 
a week are working days and which are non-working days. This is done 
considering the day definitions.  
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● Day definitions: This defines the working time and non-working time during 
the days. The day definition refers to the time types, which define whether a 
selected time span is working time or not.  

 

● Time types with minutes precision (Work or Non-work). Set the presentation 
color and pattern for the presentation in a view. 
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Export and Print the Schedule 
Export the Schedule to Microsoft Project 
1. Select File > Export on the ribbon. 
2. Select the MS Project (XML) file format, and click Next. 
3. Click Select, browse to a location where you want to save the file, name the file 

Getting Started, and click Save. 
4. click Next.  
5. To export additional data, check these boxes: 

○ Export links - Maintain predecessor and successor dependencies between 
the exported tasks. 

○ Export resource allocation - Include used resources and maintain their 
relationships to tasks 

○ Export only used library items - Exclude unused library data types from 
the exported file. 

○ Export calendars – Include TILOS calendars so you can use them in MSP. 
6. To map data fields (tokens) between TILOS and MS Project by editing the exchange 

profile, click Additional Settings. 
i. Click + to add a row. 
ii. Click in a cell under TILOS Field and use the drop-down arrow to 

select from available data types. 
iii. Click in the adjoining MS Project Field cell and select the field to 

which you want to map the TILOS data (e.g., data fields that map 
from TILOS token to MSP token). 

iv. Check/uncheck boxes to define which data types to export and make 
available for re-import from MSP. 
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7. Click OK when you are done. 
8. Click Finish. These settings will be remembered for the next time you use the wizard. 

When you open the exported file in MS Project, you will see the same data (tasks, links, 
dates, names, summary tasks, progress, resources, etc.) as in TILOS. You can make 
changes in MSP, save as Project’s native XML Format (*.xml), and re-import the file into 
TILOS. In MS Project, your user-defined fields show the TILOS-names in brackets. 

Print the Schedule 
With TILOS, you may print plans in almost any size and orientation. In the view, you may 
display your plan in the desired time and distance scale while keeping their appropriate 
proportions.  
If some object do not appear in your printed output, they may be assigned to a layer that 
has the the Visible (printout) option disabled. This print visibility option can be set 
independently for each cell. 

 

Printing Views and Gantt Charts 
You can find the Print command on the File menu, as well as on the toolbar, 
View toolbar, and context menus from various views). The Print pane includes all of 
the printer and page setup options you need to define and print most charts, lists, 
and other views.  Gantt charts are printed using the same Print pane interface and 
settings as printing integrated views and others. 

 

1. In the TILOS Explorer, double-click the Time Distance View to re-open it. 

2. Click the  Print icon on the toolbar. 
3. In the Print pane, click Select Printer, choose the Adobe PDF printer, and click OK. 
4. Make various changes to see the effects (such as how the blue, dashed pagination line 

change) in the preview: 
a. Select different formats in the Printer page size list. 
b. Toggle between the Portrait and Landscape options. 
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c. Choose different Scaling options.

 
5. When you are ready, click Print and save the PDF so you can compare the results to 

your plan.   

 

Congratulations! You have completed the TILOS Getting Started Guide. 
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Getting Help and Support 
For more information, please use these resources: 

Note on TILOS websites - All content from TILOS.org has been moved to the Trimble 
TILOS product site and the TILOS Community. TILOS downloads can now be found on the 
Downloads page in the community. 

Trimble TILOS Community 
Search for the latest content, ask a question, see answers to other user questions, start a 
discussion, or post your own helpful content. 
https://community.trimble.com/community/find-answers/civil-engineering-and-construction/sched
uling 

Technical Hotline 
● Hours: 

o Monday to Thursday: 08.30 am - 5:30 pm (GMT +1) 
o Friday: 08.30 am - 1:00 pm (GMT +1) 

● Phone: +49 721 - 4647 - 2829 (Europe) 
● Email: TILOS@trimble.com 

When contacting the hotline, please be prepared the following information: 

● Your software product ID 
● Your company name and address 
● The current software version 
● Which operating system (OS) you are working on and the assigned User Rights 

Other Contact Information 
Trimble Inc. 
G.-Braun-Str. 14 
76187 Karlsruhe, Germany 
Europe: +49 721 - 4647 > 2829 

● Americas phone: (937) 245-5154 
● Americas toll free phone: (800) 361-1249 
● Web site: https://construction.trimble.com/products-and-solutions/TILOS 

2018 All rights reserved.  
Duplication is strictly prohibited. 
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All trademarks registered. 
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