
 

TILOS 10.3​ Release Notes 
 

Build ​20191209 

 ​New &​ ​Improved 
This TILOS release includes these new features and enhancements: 

Trimble Connect BIM Integration 

When you are scheduling or monitoring progress on a large, linear construction project in TILOS, 
do you ever wish you could better visualize the structures that the tasks refer to? Well now you 
can! When you are done building the schedule and want to see where tasks are planned/work is 
taking place in a more graphical way, link the tasks to 3D BIM objects in Trimble Connect for an 
enhanced visualization experience. Your TILOS workflow remains unchanged. Viewing your 
project as BIM objects is a new, easy feature with quick benefits: in Connect, BIM models can 
provide rich infrastructure information. 

Using the new TILOS - Trimble Connect workflow, you can now: 

1. Configure a TILOS view and filter for data in Connect​ ​- In TILOS, create a project with 

a schedule of tasks as usual, and set up a view that is filtered for just the data you want 
to see in Connect.  

2. Create an associated Connect project​ - Sign in to Connect with your Trimble ID and 
create a project with information that corresponds to your TILOS project. 

3. Import BIM Data Related to your TILOS Project​ - ​In Connect, import BIM structures 

as IFC files that correspond to your linear construction project in TILOSt. These IFC files 
can be built in Novapoint. 

4. Set Up a TILOS Connection to Connect​ - In TILOS, make your connection to Connect by 
specifying the time zone, region, and task filter you want to use. This initial connection 
will push your TILOS tasks and their properties to Connect for the first time.  

5. Link TILOS tasks to BIM objects in the Connect 3D Viewer​ - In Connect, review your 
project tasks. The data you see in the Connect Organizer is identical to what is in TILOS, 
including the task names dates, durations, and completion percentages. Link any of the 
tasks with BIM objects in the 3D Viewer’s model to establish a connection between them. 
When you select a task, all linked objects will be highlighted in the model. If you pick an 
object in the model, all linked tasks will highlight in the Organizer. 
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6. Synchronize data between TILOS and Connect as you make changes​ - As scheduled 
tasks and progress change, push the new information from TILOS to Connect. If you 
import new IFC files into Connect, pull that file information from Connect back into 
TILOS. This integration enables you to understand your project schedule in the context of 
BIM objects in the 3D model. For example, if you select a road milling layer in Connect, 
you can see its start and end dates and progress. 

Task Calculations 

● Coordinate time & distance profile behavior​ - Based on your feedback about 
distance profile calculations in TILOS 10.2 MR2, the program now better reconciles 
the interaction of time and distance profile calculations. For example, the sector type 
allocated to a point now shades the area before the point, but not after the point, 
which keeps it consistent with values for the point. 

 
Important!  ​Based on this upgrade to the way​ ​profiles are used to calculate 
durations, your task dates in new projects will be more accurate (​this new 
calculation method is the default for new projects​). However, for existing projects 
in which you want dates and durations to remain as they are, you are given the option 
to keep the previous calculation method (​the old calculation method is the default 
for existing projects​). Otherwise, you can choose to enable the new calculations for 
your current projects (created before version 10.3). 

 
This new option is set by selecting Tools > Options > Project 2/General tab > Enable 
new calculation method for Time Profiles.
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● Add file links to templates - ​You can now add a file link to a task template so that when 
you ​create a new task in an Integrated View with that task template, the file link is there.  

●  ​See task IDs​ - Task IDs now appear in the File Links view.  

Scheduling 

● Add tasks to an existing summary tasks​ - You can now add existing tasks to a 
summary task on its Categories & Structure tab.  

Mass Haul 

● Automatically recalculate overhaul​ - Overhaul distance is now recalculated 
automatically when you, e.g., add an overhaul distance on a specific area of cut or fill, 
then select the same area in the Mass Haul Diagram, and change the Overhaul Distance 
value. The haul distance on the haulage is automatically recalculated as expected.  

● Select only mass haulages and mass areas​ - You can now update a selection in a Mass 
Haulage Diagram to include only mass haulages or mass areas (and exclude all other 
object types). This can decrease the time required to select individual mass haulages and 
mass areas in a diagram with many objects, and reduce the risk of missing mass 
haulages and areas in your selection or mistakenly selecting other object types.  

Work Phase Planning 

● Change Y-axis direction in distance cell​ - You can now display a site map in the correct 
direction by changing the direction of the Y-axis in a WPA distance cell. Do this by 
checking the Change direction box at the bottom of the Y-axis group in the distance cell 
settings. When this box is checked, the start and end coordinates are swapped so that 
the start distance has a larger value than the end distance; the direction of the axis in the 
distance cell changes accordingly.  

Printing 

● Print more easily​ - You can now print using either Basic or Advanced mode. The Print 
Form View appears in a single pane, and all projects and templates can have the form 
default to the paper format, e.g., A3, that you most commonly use. When you select the 
Print Form View, you can now change the settings without changing the view (the Print 
Form View opens in a new window). The Gantt Chart View also has its own Print Form 
View and print mode so that all tasks fit on one page (the size adjusts automatically). For 
Gantt charts, support for multiple pages have been added so that sizes defined in the 
Print Form View calculate how many pages are needed to print all tasks. 
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Interface/Documentation/User Assistance 

● Learn more about the TILOS - Connect workflow for BIM​ - See the  
TILOS User Community​ for assistance on these new features and how to use them. 

 

 ​Fixed 
And fixes for reported or discovered cases in which: 

Setups and Projects 

● TIL-871​ - Dragging-and-dropping a sub-project, from a folder to an open project file, did 
not work when the sub-project already existed in the destination file; even when the 
project contained few tasks, dragging-and-dropping the sub-project did not update it 
with new tasks. This issue has now been resolved. 

● TIL-838 - The Parent account ID was not being updated when imported using clipboard 
operations.  

● TIL-833 - ​Copy-and-paste did not work as expected for tasks within a Gantt chart view; 
when you tried to copy a task using the keyboard shortcuts Control+C and Control+V, 
nothing happened. 

● TIL-451 - The TILOS installer said that the program was from an Unknown Publisher, 
indicating that the ​.exe file needed to be ‘signed’ as Trimble certified software. 

 
Warning:  
Your user roaming folder will be deleted each time you close the program. If you are 
working with user-defined Excel- or Plain-Text Exchange profiles, you should export these 
profiles before closing TILOS so you do not lose them. 

 

Import/Export/Data Exchange 

● TIL-925 - An XML file exported for Microsoft​®​ (MS) Project did not show units or costs 
after importing it into Project, regardless of whether you checked/unchecked the Export 
only used library items box. Consequently, TILOS could not read the XML file when trying 
to re-import it because the tasks has no start and end dates. 

● TIL-906 - ​When you imported an MS Project XML file where categories existed in text 
fields, the selected category groups were ignored. When multi-level categories (e.g., 
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company.planning.x) were stored in the text fields, there was a bug on the import level. 
New categories were added without checking whether or not they already existed. 

● TIL-704 - Work rate could not be imported into time profiles, and you could not choose 
an existing time profile in the Seasonal field. 

Graphics/Display 

● TIL-866 - When creating a new Time-Distance cell, the cell did not inherit the distance 
range from the Tools > Options settings. 

● TIL-854, TIL-855 - When changing the annotation, line type, pattern, or border line for 
multiple tasks at once on the Properties > Display tab, there were no options to choose 
from. 

● TIL-803 ​- Applying a new filter to a task list did not refresh the list until you selected None 
in the filter list and then selected the new filter. 

● TIL-804  - ​In a Gantt chart view, the Task template menu did not display when you clicked 
Insert task. In addition, the menu did not display if you had previously clicked a task in 
the chart’s text pane. 

● TIL-802 - ​The symbol on a task with its pin point at the center was correctly positioned 
only if the task had a length. When the length=0, the symbol was not placed in the 
correct position. 

● TIL-805 -​ The last sector on a distance scale did not respect the end distance. 

● TIL-868 -​ When you added a new line to a time scale, then change the interval to 1-month 
on the Define Time Scales tab, and chose {Month (mmm)} for the label, the new line 
appeared, but the month started from the ZERO point date (which is useful only for 
relative months, weeks, or years). 

● TIL-841 -​ When you changed a milestone task graphic to a different graphic in a new 
project (created using the General.hst template), only a grey square was displayed for the 
milestone graphic. 

● TIL-806 - You could not place text after the second line of a sector because the "After 
line" option for text in a distance scale changed between versions; when you opened 
projects created in TILOS 9.0 - 10.1, the sector text placement on distance scale was not 
at the same place. 

● TIL-842 - ​The position of text in a distance scale by Sector Profile was wrong after 
converting your project file to the latest version because ​the last segment from the scale 
has no end. 
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● TIL-851 - When you connected tasks with a Distance to successor lag link, and 
rescheduled, the second task would be placed in the wrong position (before the 
predecessor task). 

Task Calculations 

● TIL-876​ - Performance profiles did not behave as expected: the dashboard Schedule 
Performance Index (SPI) was wrong when you selected the dashboard for specific tasks, 
and edited the performance profile, and added a new line. 

● TIL-402 - Project file conversion to the newest TILOS version set the link option 
incorrectly (to Sync. Duration) for version 9.1 links, causing tasks to be at different 
positions when you rescheduled.  

● TIL-878 - ​Using a task template with the calculation mode set to Calculate:Work rate and 
Set quantity by:Task length x Quantity factor, plus a value in the Quantity factor field, 
when you changed the quantity factor in the task template, then adjusted the task to 
Task Template, and checked the Calculation Data box, the Quantity factor value of 
existing tasks did not inherit the new quantity factor value. 

● TIL-870 - A ​No Work entry appeared as a milestone when you enabled the Interruption of 
Work option. Instead of a vertical task appearing to show there was no progress during 
the period, a milestone appeared in the Time-Distance view. 

● TIL-877 - ​Dashboard profile changes did not propagate; when you modified your 
dashboard profile, and applied changes everywhere the profile was used (such as adding 
SPI to your performance profile), the value was added to the dashboard, but all other 
dashboards using the same profile were not updated automatically. The SPI field was 
missing, so you had to reload the profile on each dashboard. 

● TIL-907 - TILOS 10.2 MR3 crashed when you entered task progress, regardless of whether 
the report date was changed separately. 

● TIL-867 - Various issues were encountered in float calculations when used with the 
Exclude from Rescheduling option: 

○ Total Float and Free Float were calculated when they should have been excluded 
from rescheduling. 

○ Floats for predecessor tasks were calculated considering the milestone, which 
was not correct.  

○ The critical path was incorrect.  
○ An error message appeared on the milestone even when it was excluded from 

rescheduling; the message should not have displayed.  
○ Differences existed between float values on the Floats tab and values in text 

fields. 
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Scheduling 

● TIL-819 - Milestones disappeared from a Ganntt chart view. 

● TIL-848​ - ​A rounding error occurred on​ ​links with a lag type of Equipment mobilisation 
and a speed profile. 

● TIL-847 - ​When you had tasks displaying Free floats and Total floats in a Time-Distance 
view, you could not select a task by ‘windowing’ around it; to select the task you had to 
include the float in the selection window also. 

● TIL-849 - A successor task was in the wrong position after rescheduling, causing a clash 
between tasks when: 

○ The 1st task used duration from speed profile and length 
○ The 2nd task was a parallelogram (elapsed) with negative "Start time and end 

time" 
○  The task link was Distance to successor link with "Consider task shape" activated  

● TIL-843 through TIL-846 - In a few scenarios, ​various issues were found when rescheduling 
with constraints; these occurred when there were a mix of tasks with ALAP, ASAP, and 
specific date constraints in the same project. 

● TIL-882 ​- Sector shading was not in the correct position when using Distance Profile in a 
distance scale to show specific areas in which you had a different speed. A new line 
appeared, but sector colors were not in the right place.  

Mass Haul 

● TIL-910 - ​When you checked the Display Haul Quantity box, sometimes the Display Haul 
Qty bar moved above the mass area’s rectangle. 

● TIL-852 - ​Mass haulage cut quantities were being taken incorrectly: when you created a 
link to move earth from cut to fill using the yellow minus sign, the Cut Qty (compacted) 
was being taken from the Cut Remaining Qty, instead of considering the remaining fill 
qty, causing too much material to be moved to the fill destination. 

● TIL-831, TIL-832, ​TIL-840​ - New mass area types and haulage types duplicated by 
copying-and-pasting or clicking + had not only the same name, but also had the same ID 
(the ID should have been unique).  

● TIL-830, ​TIL-839 - ​New mass area types and haulage types were being created in the 
library without an ID (the field was empty). 
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Work Phase Planning 

● TIL-904 - When using a WPA license in versions 10.2 MR2+, the Insert Point Features was 
missing. 

Printing 

● TIL-83​7, TIL-835 - New accounts duplicated in the library by copying-and-pasting or 
clicking + had the same account ID (the ID should have been unique).  

● TIL-825 - Print page size options were confusing when the selected printer was not 
recognized/compatible. 

● TIL-890 - When printing a grouped Gantt chart to PDF (using the Default Print View Form 
and Set Pages Size to View Size enabled), incoming links were missing if a predecessor 
task was not on the same PDF page. 

Other 

● TIL-886 - New calendars duplicated by copying-and-pasting or clicking + had the same ID 
(the ID should have been unique). 

● Also see ​Known Issues​ below. 

 

 Other 

Known issues 

● TIL-853 - If you have more than one version of TILOS installed, when you right-click on an 
HSP project file and choose "Open with", the latest installed version of TILOS is not 
available as an option (occasionally, the option may appear). This is a Microsoft​® 
Windows operating system issue. 

● From resolved Printing issues above:​ In rare cases, when you try to print a Gantt chart, 
either it will not be positioned correctly on the page (causing part of the chart to be cut 
off) or the size may be incorrect (so more pages are printed). To fix this: 

1. In TILOS Explorer, open the Gantt chart you want to print. 
2. Select File > Print on the menu. 
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3. In the Print pane, select a print template in the Template view list. 

 
4. Close the Print pane. 
5. In TILOS Explorer > Views > Print Form for Gantt Chart, double-click the same 

print template. 
6. Select File > Print on the menu to re-open the Print pane. 
7. Check the Set page size to view size box. 

 
8. Close the Print pane. 
9. Re-open the Gantt chart and try printing again. Anything else you print in the 

same project will print as expected. 

● This reported issue works as designed:  In a summary task with linked child tasks, if a link 
is driving, the summary task and its children are moved toward the future, but if the link 
is not driving, the summary task and its children do not get moved towards the past. 

○ The designed behavior is: Unlinked child tasks in a summary task keep their 
position; tasks under a summary task are not moved if they start later than the 
earliest possible start date for the summary task. 

● It was reported that using the TILOS MS Project (XML) exporter, a distance-split, 
progressed task was imported into MS Project with incorrect data; the duration, start 
date, and end date were wrong. After investigation, it was determined that the XML 
exported from TILOS was correct, but that MS Project recalculations (likely based on 
resource availability) caused the error. This is a problem outside of TILOS. The 
workaround is to avoid importing resources into MS Project.  
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Supported Languages 

TILOS program interface is available in these languages: 
● Chinese (Mandarin) 
● English 
● French 
● German 
● Hungarian 
● Italian 

●  
● Korean 
● Polish 
● Russian 
● Spanish 
● Turkish 

It is possible to run more than one language edition on the same computer. 

TILOS program help is available in these languages: 
● English 
● German   
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Reaching Sales, Support, and the Community 
For more information, please use these resources: 

Trimble TILOS Community 

Search for the latest content, ask a question, see answers to other user questions, start a 
discussion, or post your own helpful content.  

https://community.trimble.com/community/find-answers/civil-engineering-and-construction/scheduling 

Technical Support Hotline 

● Hours: 
o Monday to Thursday: 08.30 am - 5:30 pm (GMT +1) 
o Friday: 08.30 am - 1:00 pm (GMT +1) 

● Phone: +49 721 - 4647 - 2829 (Europe) 
● Email: ​TILOS@trimble.com 

When contacting the hotline, please be prepared the following information: 

● Your software product ID 
● Your company name and address 
● The current software version 
● Which operating system (OS) you are working on and the assigned User Rights 

Other Contact Information 

Trimble Inc. 
G.-Braun-Str. 14 
76187 Karlsruhe, Germany 
Europe: +49 721 - 4647 > 2829 

Sales and Product Information 

● Europe phone: +49 721 - 4647 - 2829 
● Americas phone: (937) 245-5154 
● Americas toll-free phone: (800) 361-1249 
● Web site: ​https://construction.trimble.com/products-and-solutions/TILOS 

 

Trimble 2020 All rights reserved. Duplication is strictly prohibited. All trademarks registered. 
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