View Only
Expand all | Collapse all

Can't publish the design to Earthworks from WorksManager

  • 1.  Can't publish the design to Earthworks from WorksManager

    Posted 05-16-2023 00:42
    Edited by 奈生 中村 05-16-2023 00:44

    Hello everyone,

    I have a difficult issue about the design published.

    I added the design in WorksManager and published it to EW machine.
    There is no error message in WM and I confirm the design was published to TCC server.
    Off cause, I check that EW connected the TCC by Conncected Community tab (@WebUI).
    However in EW, I can't find that design. I tried to sync manually, but not worked.

    This issue has ocurred some accounts, they are not same EW version.
    So I think the system error causes this issue...

    If someone knows this issue, please let me know :(

    Sitech JAPAN

  • 2.  RE: Can't publish the design to Earthworks from WorksManager

    Posted 05-16-2023 01:23

    Did you restart Earthworks on the machine. I've seen it multiple times that the design won't show up in the list after an online synch to TCC, if EW was not restarted. That totally negates the point of automatic background synchronisation.
    You'll have to swipe up from the bottom of the screen, press the square icon and close EW. Once you restart EW the newer designs should show up in the list.

    Unless, your design is a VCL type, direct upload from TBC to Worksmanager and from there to EW, and the EW version is older than 1.9.
    According to my old EW release notes VCL was supported from 1.9 onwards.

    The design was probably uploaded to the machine, but the EW version might not understand it.
    You can check this by either remote accessing from Worksmanager or directly on the machine in the AdminUI interface and by browsing the file system.
    We do have one machine on site that has such an old version, a Volvo with DigAssist and special EW version that supposedly can't be updated.

    Ronny Schneider

  • 3.  RE: Can't publish the design to Earthworks from WorksManager

    Posted 05-16-2023 02:37

    Thanks Ronny-san

    Sorry, my post has not much information.
    This issue has occurred since 1 week ago, so EW of this machine has already been restarted many times.
    And still no design in EW...

    I know the VCL file limitation and this machine has EW v2.7.2, so no problem.

    I confirmed the file storage in the AdminUI, but there was no design and no project I uploaded.
    I have synchronized manually many times.

    Have you ever encountered this issue like?
    If so, please let me know how to solve.

    Sitech JAPAN

  • 4.  RE: Can't publish the design to Earthworks from WorksManager

    Posted 05-16-2023 15:04

    If the project is prepared by Worksmanager and is available on TCC and the design is ticked to be published for that certain machine and is still not uploading to it, then there is a problem again between Worksmanager and Machine.

    You can try to unpublish all designs for all machines and then republish them, that may fix it.

    We did have problem about 2 years ago when suddenly designs disappeared from EW machines. Took the Worksmanager guys 2 month or so to acknowledge and fix it.
    Since there is only one single ProjectLibrary on TCC the server needs to decide, based on the EC520 serial number, which projects/designs a machine is supposed to see/load.

    As a workaround we did create a manual copy of the projects folder on TCC and set the machines to synchronize to that one. Since that folder will be unknown to Worksmanager it can't interfere with it and the machine will load everything that is in this folder.

    Ronny Schneider