View 2D Files and 3D Models

Document created by Jose Gonzalez on Dec 16, 2016Last modified by Jose Gonzalez on Mar 1, 2017
Version 4Show Document
  • View in full screen mode
Click the icon to skip to the section you are interested in.
Feature supported in shown platforms only.

Trimble Connect Web

View Files and 3D Models
With Trimble Connect you can view both 2D and multiple 3D files directly on your browser.

Loading a Model in The Viewer

    1. Go to the Data tab and select a 2D or 3D file by checking the box to the left of the file name. Once checked, you can see a preview of the file in the right panel:
    2. From the Viewer toolbar, click the View icon  or click on the thumbnail in the right panel. The file name can be clicked directly to load it in the viewer as well.
    3. The file will now open in the Viewer:

 

Loading Multiple Models

      1. Multiple 3D models can be viewed at the same time in the 3D Viewer. From the Data tab, select multiple 3D files and click on the Viewer icon to open them in the Viewer.

 Note: As a project admins there are additional 3D settings here - Project 3D Settings

 

SketchUp files

Now SketchUp files can be viewed in the My SketchUp web viewer. All the SketchUp files on the project will now have a SketchUp button. Select the file from the data page and see information on the right pane. Click the SketchUp button to launch the My SketchUp web viewer in another tab.

You can view the model on the SketchUp web and use the tools from the extreme right center.

 

Trimble Connect Desktop

Viewing Models
The Models  list displays all the models that are included in your project. Also the Data tab lists the models in a project.  Several models can be included, such as architectural, structural and MEP models, in a single project. The models can be grouped into model groups.  You can dock or undock the Models list, and move it around the 3D view.

View Models included in a Project
The Models list displays all the models that are included in a project.
The models also are added on the Data tab

View Model Properties
Double-click the selected model in the Models list to open the model property pane, or click .

Select Models for Loading
On the Data tab, in the Models pane, click  to select all models for loading. The models are loaded also to the 3D View tab.

If you do not need to work with all the models at the same time, you can load single models, or if you have created model groups on the 3D View tab, you can load a model group and its models.

To select single models, select the checkbox next to the model.

Model Groups

Create a New Model Group to the Project
You can group models to model groups and this way manage models easily.

      • To create a new model group, click the 'New Model Group' button.
      • Alternatively, right-click in the Models list and select Create group.

A new model group with the name New group is created.
The new model groups are visible also on the Data tab, in the Models pane.

Add a Model to a Model Group
Drag and drop models to the model group you want to add them.

Rename a Model Group

      1. In the Models list, select the model group that you want to rename.
      2. Right-click and select Rename.

Load or Unload a Model or a Model Group

      • In the Models list, select the check box in front of a model or a model group to load the model to the project.
      • Alternatively, select the check box in front of a model or a model group on the Data tab, in the Models pane.

The models are loaded and shown in the 3D view. When a model group contains loaded and unloaded
models, the check boxes look like this:

Note that if you unload the models, the model objects are removed from the Objects list . If you hide the models using the visibility symbol , then the model objects are listed in the Objects list.

Show and Hide Model Groups, Models and Assemblies
You can show and hide models and model groups using the Models list .

If the model is in .ifc format, you can show and hide the assembly level information as well.

      • To hide a model group, a model or an assembly, click the visibility symbol 
      • To show a model group, a model or an assembly, click the visibility symbol .

When a model group, a model or an assembly contains hidden and shown objects, the visibility symbol looks like this: 

 

If you select an assembly in the Models list, the assembly is highlighted in the model.

If you select an assembly in the Models list and double-click it, the assembly property pane opens and displays the assembly information. In the assembly properties pane you can click the Zoom to Object or Select Object button and view the assembly in the 3D view.

Remove a model or a model group

      1. In the Models list, select the model or model group you want to remove.
      2. Right-click and select Remove.
        When you remove a model, the local copy of the model file is removed. If you have uploaded the model to the server, the model still exists on the server.
        When you remove a model group, the local copies of all the model files in the group are removed. If you have uploaded the models to the server, the models still exist on the server. 
        The model files can be downloaded again from the server on the Data tab, if needed.

 

Trimble Connect Mobile

With the Trimble Connect Mobile, you can:

  • Display models and model groups in the 3D Viewer
  • Create a new model group that contain various models
  • Display all models in a model group in a single 3D Viewer
  • Show/hide a model or layer in the 3D viewer
  • Filter model parts based on their property name and property value
  • Remove a model or model group 

 

 View Files and 3D Models

After a project name is clicked in the main page, the DETAILS page of the project is displayed. Click the DATA tab  to display all data (folders and files) included in that project. 

In the DATA tab, the items listed are:

  • the folders containing the files and folders 
  • the 2D files 
  • the 3D files 

 

 And, the status indicators associated with the files and folders are: 

  • a file not yet downloaded from server 
  • the folder/file is up-to-date with the server 
  • a local copy of file is available, but it is not up-to-date with server file 
  • a file for which the download has failed 

  

 Loading a Model in The Viewer

Once the files are downloaded, you can view the 2D or 3D model in the Viewer. 

To view model, follow the steps:

  1. In the DATA tab , click on the file that you want to view; on doing so, a temporary toolbar will appear at the bottom.   

  2. From the temporary toolbar, click the green-colored eye button. The model appears in the Viewer. 

 

 View Model Properties 

To view the properties of a model:

  1. Select the model and click the green-colored eye button. The viewer will open with the model.
  2. In the viewer, click on the model for which you need to view properties and then click the  button located in the upper-right corner. The Model View menu will open with id of the selected model.
  3. Click on the right-arrow next to the model id. The Properties page will open with the model properties.    
  4. You can use the Search functionality to search for a specific property in this page.

 

 

 

 

 

 

 

 

 

 

 

 

 

 Model Groups

 

 Select Models for Loading

On the DATA tab, you can select all models by clicking on each of the list item(s). All selected list items will be highlighted and the total number of models selected will appear at the bottom of the list pane.

 

You can click the X DESELECT ALL button to deselect all selected models in the list panel.  

 

 Loading Multiple Models

You can view multiple models in the Viewer.

To view multiple models, follow the steps:

    1. Select the models by clicking on each of the file names in the DATA tab.
    2. After selecting multiple models, the total number of models selected will be displayed in the green-colored eye button.
    3. Click the green-colored eye button to view all models in the same viewer. On doing so, the model(s) selected appear in the same Viewer.

 

Create a New Model Group to the Project

You can create a new model group that will contain the models selected in the list panel. Moreover, you can create a new model group with one or more selected models.

To create a new model group:

    1. Select single or multiple model files from the list panel.
    2. Click the  button in the bottom toolbar. The NEW MODEL GROUP page will display.
       
    3. Type the name of the new model group in the Name text box.
    4. The Contents section shows the models included in the current model group. You can remove any of the model from the current model group by clicking the X button next to that model. 
    5. Click the Check Mark button. A new model group is created with the typed name.

 

Editing a Model Group

After creating a model group, you edit the name and content of that model group. To display all model groups, click the Filter button  and select the ModelGroups option. All model groups in the current project are displayed in the list view.  

Example image showing the list of model groups in a project.

In the list model groups, click the right-arrow button (>) for the model group that you want to edit. The EDIT MODEL GROUP page will open.

 

Example image showing the EDIT MODEL GROUP page.

 

In this page, you can either rename the model group or modify the content.

 

Rename a Model Group

You can rename the current model group by changing the name in the Name text box. Then click the  button to save your changes.

 

Add a Model to a Model Group

You can add one or several models to the current model group.  

To add model(s), follow the steps:

    1. Click the  button in the Contents row. The ADD MODELS TO GROUPS page appears with the project link.  
    2. Browse through the project location and select the model(s) that need to be added. 
    3. Click the ADD MODELS TO GROUPS button located on top of the page. All selected models are added to the current model group.

Remove a Model from a Model Group

You can remove any of the model(s) from a model group by clicking the X button next to that model in the Contents section.

  

Show and Hide Model Groups, Models and Assemblies

You can show, hide, or remove Model Groups, Models, and Assemblies from a project. 

To show model group(s) in a Viewer:

    1. Click the Filter button  and select the ModelGroups option. All model groups in the current project are displayed in the list view.
    2. To view a model group, click that model group from the list view and then click the green-colored eye button  The models inside the model group appear in the Viewer.
       

 

By default, all models in a model group are displayed in the 3D Viewer. To specify which models need to be hidden, follow the steps:

    1. In the 3D viewer, click the  button in the top toolbar. The 3D Viewer page appears with the list of all models.

       
    2. In the 3D Viewer page, you can hide any of the models by clicking the eye icon  before that model. Also, you can click the LAYERS tab located at the bottom of the page to view all layers in the current models.
    3. Click the 3D Viewer title of the page to return to the 3d viewer.

 

To view only a specific part of model in the Viewer, follow the steps:

    1. In the Model View page, click the  button. 
    2. Type required values in the Property Name and/or Property Value text box(es), and then press Done. Only the filtered part of the model will be displayed in the viewer.

    3. To clear filter and display all parts of a model, click the  button from the bottom toolbar. 

 

Remove a model or model group 

You can remove a model or a model group by clicking on it and then clicking the  button. Then click the OK button on the confirmation alert message. 

Attachments

    Outcomes