AnsweredAssumed Answered

Siteworks Error "Index was outside the bounds of the array"

Question asked by Shaun Carman on Jul 2, 2020
Latest reply on Jul 7, 2020 by Alan Sharp

I am running TBC 5.30 and Siteworks 1.20.20102 Build 355 on a TSC7.  I am creating a road surface in TBC and using the WorksManager commands to create the files and upload to WorksManager.  On the controller I can load the design without error as long as their is no surface selected.  If I select the surface (there is only one) then I will end up getting the error message:  "Unhandled application crash (details in TrimbleLog20200702_150041.elg).  Please reset controller.  Exception message: Index was outside the bounds of the array." I have attached the diagnostic file.

 

I have also tried this using as a regular surface instead of a road surface and the same error occurs.

 

Not sure what is happening.  If I create files like I do for SCS900 using the exact same surface and lines then it will load it with no problems i.e. a DXF and PRO file.  As soon as I try to use the VCL generated file (I have attached it) then it will not load without error.

Outcomes