Mapping and GIS Solutions Community

 View Only
Expand all | Collapse all

Not connecting to satellites

Jump to Best Answer
  • 1.  Not connecting to satellites

    Posted 01-15-2020 19:54

    Hi, 

     

    I have had a Trimble Catalyst for almost 1 year now, but have not used it since June 2019.  Previously everything worked fine. I purchased a month subscription to go through mid February 2020 and followed the same setup procedures as before and everything seems OK- cellphone compatible, Catalyst app running in the background, Trimble Mobile Manager connection is fine, subscription shows up, connection from phone to Catalyst is fine, battery pack is connected to Catalyst, satellites are showing up, but it will not connect to any of the satellites and if it does it will only be connected for 1 or 2 seconds and is dropped.  I am trying to connect in an open field so there should not be any interference.  I removed and re-installed the Catalyst app and Trimble Mobile Manager to make sure it was not an app issue.  The only thing I can think of is there is something wrong with the antenna, but I am unsure how I can diagnose that.  Any guidance is appreciated.

     

    Thanks!



  • 2.  Re: Not connecting to satallites

    Posted 01-16-2020 04:03

    Hi Timothy

     

    This sounds like you could be running outdated firmware or some other compatibility issue, we've had a large number of updates, enhancements and releases in the last 12 months which you can review here so I suggest you do the following:

    1. Log into Trimble Mobile Manager
    2. Generate and Send the log files - it is very important you provide a description in the email before sending 
    3. This will go through to the support team who can analyse the logs, see whats going on and get back to you with a solution


  • 3.  Re: Not connecting to satallites

    Posted 01-16-2020 04:04

    I was able to resolve the issue.  Battery was on optimization mode for the Trimble catalyst background app so I believe the phone was limiting the power usage, not allowing it enough power to maintain connection.  I turned off battery optimization everything worked.



  • 4.  Re: Not connecting to satallites
    Best Answer

    Posted 01-16-2020 04:28

    That's correct and thanks for the update Timothy

     

    Having Android's battery optimization enabled can limit system resources allocated to background apps and services,in order to conserve the battery life of the device.

    We recommend you disable this for the Catalyst service and application(s) 

     

     

    As an FYI - How do you know if battery optimisation is enabled..?

     

    1. In Trimble Mobile Manager select the Applications Settings option
    2. If you can see the Battery Optimisation option then this is enabled
      BatteryOpt
    3. Select OPEN SETTINGS
    4. By default this will display Apps not optimised - change this to ALL
    5. You can then scroll to find the Trimble Catalyst Service and Trimble Mobile Manager apps or use the search function (as in the example below)
    6. Use the slider to disable and return to TMM
    7. The Battery Optimisation option will not longer be visible in the Application Settings

     

    #catalyst #trimblecatalyst #batteryoptimistaion