Trimble Business Center

 View Only
Expand all | Collapse all

Issue: Command object threw an exception

  • 1.  Issue: Command object threw an exception

    Posted 07-14-2020 21:17

    I am unable to import CAD linework via drag-and-drop or discrete import command. I receive the following vague error:



    This error affects both DXF and DWG linework import attempts, and is a new problem for this file, though I have experienced it previously in other projects. These CAD files are not open in other programs while trying to import. 


    This does not affect other file imports (ie XML, CSV, XYZ, etc.)


    As can be imagined, I need to be able to add more data to my project, and I need to do so as quickly as possible, preferably without creating a new file.


    Is there a way to resolve or otherwise get around this error?


    If there isn't already, it would be excellent to have more context and/or information as to the origin of the error. Additionally, it would be great if a log report was generated for errors such as these.

  • 2.  Re: Issue: Command object threw an exception

    Posted 07-14-2020 21:24

    Can you import it into another New and Blank Project. If Yes - do that and then export it as a VCL file and then import that into your other project. If that also fails can you share a file or email it to me and I will take a look first thing in the morning.



    What version are you running?





  • 3.  Re: Issue: Command object threw an exception

    Posted 07-14-2020 22:09

    TBC v5.30

    Windows 10; 


    I have deleted my computer's temporary files, restarted Business Center, and restarted my computer and still get the same error when trying to import CAD files.


    I also followed your suggestion to create a VCL of my desired CAD data, but on importing into my base drawing I still received the same error.

  • 4.  Re: Issue: Command object threw an exception

    Posted 07-15-2020 08:05


    It is either the file is a problem, but if all CAD files are showing this issue then it sounds more like a TBC issue, but I know CAD files import OK for many people so that points at a local installation problem. If it did work for a while and has stopped working or if it never worked it is likely that you have a corrupted file somewhere, and the first thing to try is a deinstall / reinstall or a deinstall / cleanup utility / reinstall if the deinstall / reinstall doesnt work.


    If I can get the file that is causing you issues I can try that for you on my end to see what happens for me, but I use v5.30 all the time and I get CAD files every day to look at and I have not seen this issue at all, so it does look like a file or install issue to me from the info provided so far.